Author Topic: Plug-in version 2.2.3 and the re-design universes  (Read 6638 times)

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Plug-in version 2.2.3 and the re-design universes
« on: 22 August 2009, 19:50:58 »
The Wiki says that version 2.2.3 is for "all redesign universes". Uhm, has it actually been tested for the various languages of the redesign universes? Some of them are very new - I somehow find it doubtful that there have been enough collected espionage reports and galaxy views from them to test all the various strings (which might have changed, BTW).

Yup, just got a bug report from the Russian language Andromeda:

Quote
Error at create_status_tab: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: XStringBundle :: getString :: line 17" data: no]

Sounds like some kind of Unicode problem? (Russian uses the Cyrillic alphabet.) Don't know yet when the above happens (i.e., when viewing espionage reports, galaxy views or something else). Will add more information, when it becomes available.

Is there any way I can help locating the problem? Do you need collected espionage reports, galaxy views or anything else?

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #1 on: 22 August 2009, 20:45:18 »
BTW, in case somebody feels like testing, the following servers now have redesign universes:

ogame.cz(Czech)
ogame.de(German)
ogame.org(English)
ogame.com.es(Spanish)
ogame.fr(French)
ogame.gr(Greek)
ogame.it(Italian)
ogame.onet.pl(Polish)
ogame.com.pt(Portugese)
ogame.ru(Russian)
ogame.com.tr(Turkish)
ogame.us(American)

The plug-in probably works for the English, American and German servers, but it needs to be tested on the others - especially the "bizarre" languages like Russian and Greek.

Offline puremind

  • **
  • Posts: 6
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #2 on: 22 August 2009, 22:41:57 »
If this helps:
 
The plugin 2.2.3 works quite well for the Spanish Andromeda.

There are some text errors like "unknown universe" displayed, but the plugin sends the information correctly to GT 4.5.1

I detected that if an Alliance has a blank name, the plugin gets "crazy" and does not upload the 100 records in the stats view, and also, if you are researching a tech or building, the plugin does not update the records until the queue is finished (I ignore if this behaviour is on purpose or not).

The rest looks like it is working correctly, which is very good.

Thanks for the effort.

Offline Omar Hawk

  • Administrator
  • ****
  • Posts: 900
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #3 on: 22 August 2009, 22:48:39 »
bontchev, you missed some languages ;)

I tested the plugin already and the only real bug I found was Issue #355

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #4 on: 23 August 2009, 07:31:27 »
bontchev, you missed some languages ;)

I did? Uhm, which ones? I thought I'd been pretty thorough... Note that I'm talking only about the languages that currently have re-design universes - not all languages supported by OGame. There are many others, that still don't have a re-design universe, of course. Trust me, being Bulgarian myself, I wouldn't have missed the Bulgarian language without a good reason. ;)

Quote
I tested the plugin already and the only real bug I found was Issue #355

Well, as I said, the people on the Russian server are definitely having problems. Too bad that I don't have an account there (and its Andromeda universe is already full anyway) - so I have to rely on reports from third parties... But I told them to collect HTML sources of the pages that cause the problem, so hopefully soon I'll have something more substantial to report.

Offline Omar Hawk

  • Administrator
  • ****
  • Posts: 900
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #5 on: 23 August 2009, 18:42:02 »
bontchev, you missed some languages ;)

I did? Uhm, which ones? I thought I'd been pretty thorough... Note that I'm talking only about the languages that currently have re-design universes - not all languages supported by OGame. There are many others, that still don't have a re-design universe, of course. Trust me, being Bulgarian myself, I wouldn't have missed the Bulgarian language without a good reason. ;)

No, indeed you missed

ogame.nl (Dutch)
ogame.com.br (Brazilian)
ogame.ro (Romanian)

Offline Sundown

  • **
  • Posts: 14
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #6 on: 25 August 2009, 05:29:44 »
Hi! Im from Brazil and just create an account on Andromeda in ogame.com.br. Also i created an account on http://www.galaxytool-hosting.eu/ and got the newest version of galaxytoolbar (2.2.4).

I have the exact same problem posted above

Error at create_status_tab: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]

This window appears three times when i go to the galaxy tab and i cant update any data at all :S

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #7 on: 25 August 2009, 05:49:29 »
This window appears three times when i go to the galaxy tab and i cant update any data at all :S

Just guessing - are there 3 debris fields in the solar system you're looking at when this problem occurs?

Offline Sundown

  • **
  • Posts: 14
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #8 on: 25 August 2009, 06:30:50 »
No there is none. Our server was created last thursday.
Actually i realize im getting this problem in every tab that GT can get any kind of information like hangar, buildings, researchs and alliance page

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #9 on: 25 August 2009, 09:51:03 »
If anybody's counting, the

ogame.dk(Danish)
ogame.hu(Hungarian)

servers now have redesign universes too.

Offline Omar Hawk

  • Administrator
  • ****
  • Posts: 900
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #10 on: 25 August 2009, 11:15:43 »
Hi! Im from Brazil and just create an account on Andromeda in ogame.com.br. Also i created an account on http://www.galaxytool-hosting.eu/ and got the newest version of galaxytoolbar (2.2.4).

I have the exact same problem posted above

Error at create_status_tab: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]

This window appears three times when i go to the galaxy tab and i cant update any data at all :S

Someone had already the same problem. The only thing that has helped him was to uninstall Firefox including all Add-Ons, and then to reinstall it. (So it was a firefox poblem)

Creating a new browser profile didn't work...

Offline Sundown

  • **
  • Posts: 14
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #11 on: 25 August 2009, 22:53:56 »
All other brazilians that i talked said they are getting the same problem. They said there was some incompatibility with the new firefox version.

But I will try this solution and see if it works

antikiller

  • Guest
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #12 on: 26 August 2009, 11:09:19 »
Quote
Error at create_status_tab: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: XStringBundle :: getString :: line 17" data: no]

This error is related to Firefox with Russian localization, not Russian Andromeda uni.
I've installed the addon at English Firefox and it works fine with Russian server. But my  friends use Russian Firefox and get the error above.

Offline Sundown

  • **
  • Posts: 14
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #13 on: 26 August 2009, 12:27:57 »
Quote
Error at create_status_tab: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: XStringBundle :: getString :: line 17" data: no]

This error is related to Firefox with Russian localization, not Russian Andromeda uni.
I've installed the addon at English Firefox and it works fine with Russian server. But my  friends use Russian Firefox and get the error above.

its just the same with our Firefox (Brazilian) :S

i could just change the distribution and get it to work, but its unreasonable with all the other users so i think for now its better to wait for a new version of the plugin :D

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: Plug-in version 2.2.3 and the re-design universes
« Reply #14 on: 26 August 2009, 15:18:47 »
Additional language servers sporting re-design universes:

bg.ogame.org(Bulgarian)
mx.ogame.org(Mexican)
ogame.se(Swedish)
ogame.sk(Slovenian)