Author Topic: When GTPlugin compatible with numeric and named Universes?  (Read 2574 times)

Offline puremind

  • **
  • Posts: 6
    • View Profile
Hi:

Just a quick question:
Are you trying to program the Plugin to allow to upload data froma numbered universe AND a named one?
Is there an estimate date for release?

We do have an alliance using GT for 2 years in universe 13, and now we areplaing Andromeda but 2.1.10 works in the 13th and 2.2.3 works in Andromeda, but neither of them work with both.

I'd say that a simple IF is this univere parse this way and ELSE parse that way, and problem solved.

Anyway, just asking.

Thanks.

Offline linkarned

  • *
  • Posts: 1
    • View Profile
Re: When GTPlugin compatible with numeric and named Universes?
« Reply #1 on: 22 August 2009, 13:49:09 »

We do have an alliance using GT for 2 years in universe 13, and now we areplaing Andromeda but 2.1.10 works in the 13th and 2.2.3 works in Andromeda, but neither of them work with both.

You took the words right out of my mouth there word for word of i also have uni13 gt and an andromeda gt but cant get the plugin to work on both.

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: When GTPlugin compatible with numeric and named Universes?
« Reply #2 on: 22 August 2009, 18:03:24 »
It is not so simple. The two plug-ins are for the old-style and for the redesigned OGame respectively - not for numeric and alphabetical universes. For instance, some of the numeric universes are redesigned universes - 42 on ogame.org and 6 on ogame.de.

I do agree, however, that either a single plug-in or two plug-ins being able to work in concert are really needed to help people who play both in the old-style and in the redesigned universes. The problem of the author is that he believed GameForge's statement that "all universes will be redesigned soon" and decided that if the old-style universes will be phased out soon, there is no point maintaining two different plug-ins.

However, GameForge stated this almost a year ago and the old-style universes are still going strong. The latest development in this aspect is a statement from GameForge that they are "not sure" if the new game play (modified storage formula, planet colonization depending on astrophysics, etc.) will be introduced into the old universes or whether only the user interface will be changed. While that has no impact on the problem being discussed (the plug-in depends only on the user interface), I still wouldn't bet that the old universes will switch to the new user interface any time soon - and meanwhile the users are forced to decide whether to use GT only for the old-style universes or only for the new-style ones.

Why is it a problem to have two compatible plug-ins? You just need to change the plug-in ID and to put some trivial logic to detect which user interface is used...

Offline puremind

  • **
  • Posts: 6
    • View Profile
Re: When GTPlugin compatible with numeric and named Universes?
« Reply #3 on: 22 August 2009, 22:45:35 »
More than probably they will take a lot of time to do the changes.
Just think that they can't add the Astrophysics tech to the old ones, and all the other stuff like different values for the depots.
That will break all the previous stuff done by the players!!!
I think that the numeric unis will die like they were born: "text-based".

The idea of having 2 plugins sound good to me, just if the 2.2.3 were not detected as a higher version of 2.1.10 and installed separatedly they should work fine with minor changes I guess, and that should sort all the issues.

Regards.

Offline bontchev

  • ****
  • Posts: 408
    • View Profile
Re: When GTPlugin compatible with numeric and named Universes?
« Reply #4 on: 23 August 2009, 07:23:42 »
Just think that they can't add the Astrophysics tech to the old ones, and all the other stuff like different values for the depots.
That will break all the previous stuff done by the players!!!

Yes, it will, but, apparently, GF has no problem with that. They said that after the switch, the players rank will change to a lower one (because some things like storages and astrophysics cost less) and those who already have 9 planets will be allowed to keep them even if their astrophysics level doesn't allow them to colonize that many.

But this doesn't matter in light of GF's latest decision. They have decided to, initially, just change the user interface of the old universes, without changing the gameplay (i.e., the formulas). (There is precedent for this - when ACS was introduced, it wasn't retrofitted into the universes that existed at the time. Still isn't - many old universes don't have it.)

This won't disrupt/change anything (except annoy the players, because the new interface sucks. Big time. Just IMNSHO, of course.). Still, I don't think that even that will happen any time soon.

Quote
The idea of having 2 plugins sound good to me, just if the 2.2.3 were not detected as a higher version of 2.1.10

Just re-releasing 2.1.10 with a new plug-in ID would take care of that, I think. It will just need some logic added, so that it doesn't try, futilely, to parse the info from the new-style universes. I'm pretty sure that there are elements on each page (the planet selector?) that allow the plug-in to decide whether it's looking at the old-style or the new-style user interface.

Offline puremind

  • **
  • Posts: 6
    • View Profile
Re: When GTPlugin compatible with numeric and named Universes?
« Reply #5 on: 24 August 2009, 19:15:13 »
Actually, I have the settings set for uni13 and Andromeda.

I don't change them, I just change the plugin version if I want to upload to one or another, so ... it shouldn't be difficult to "patch" this situation and allow the players to upload to both universes with the same plugin or just using 2. !!! :D

Hope this comes soon or the guys @ my alliance will start to be impatient ;)

Regards.