Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - bontchev

Pages: [1] 2 3 ... 7
1
Problems / Cron jobs?
« on: 11 August 2013, 10:18:00 »
From the changelog:

Quote
* Admins can now create cronjobs to load the OGame API data on a regular basis.

How is this done? I couldn't find such a capability on the Administration menu.

2
Problems / Updating doesn't work
« on: 21 March 2013, 11:03:07 »
After the "server maintenance" it is no longer possible to update the tool hosted by galaxytool-hosting.eu. I get an error message like

Could not find OGame API at uni44.ogame.org/api/alliances.xml

despite the fact that the API is perfectly accessible:

http://uni44.ogame.org/api/alliances.xml

Did something go wrong with the rights to download from other sites?

3
Ideas / Disable the registration from the login page
« on: 20 December 2012, 05:22:39 »
Please, make it possible for the administrators of the tool to disable the ability of new users to register from the login page. For some reason, lots of people who have nothing to do with our alliance register to our tool (hosted at galaxytool-hosting.eu, BTW). They can't do anything, of course, unless an administrator approves them, but I am fed up having to delete them.

4
Problems / Bizarre error
« on: 18 December 2012, 05:08:02 »
Version 2.6.25 of the plug-in for Firefox causes a lot of bizarre errors on the error console when the browser accesses a Web page that does not belong to the game. Here is an example:

Quote
Error: uncaught exception: [Exception... "Could not convert JavaScript argument arg 1 [nsIDOMEventTarget.removeEventListener]"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: chrome://galaxyplugin/content/init.js :: anonymous :: line 174"  data: no]

I am still using Firefox 3.6.28; dunno whether this problem happens on the new versions of the browser.

5
Problems / Phantom debris fields
« on: 31 October 2012, 08:37:27 »
This is terribly annoying but so far I've been unable to reproduce it reliably. It happens a lot - but I can't nail down the exact conditions. What is worse, I don't even know whether it is a problem in the plug-in submitting wrong data or in GT getting the data incorrectly. I've filed a bug report.

In short, phantom debris fields keep appearing in the database. It seems to happen when, while scanning the Galaxy and spying inactives, I look at a system where there are debris. From that point on, this debris field is "replicated" at the same position in every other system I look at. It doesn't always occur - but once it starts occurring, the only way to stop it is to click on the Galaxy button again - i.e., completely refresh the Galaxy page. Just updating it by looking at another system will simply replicate the phantom DF to that system.

Problem is, I can't nail down the exact conditions under which it starts happening. It might be related to full fleet slots (because when I'm scanning the inactives my fleet slots are full practically all the time) - but I am not sure; I think I've seen it happening when there are available flight slots and it certainly doesn't always happen when there are none.

I've tried turning on the debug information in the plug-in - but, of course, in those cases it doesn't want to happen. >:( And I can't keep the debug info on all the time; it covers parts of the screen and is generally annoying.

So, I don't know if the plug-in for some reason reads incorrect data and sends it to the database - or if the database keeps carrying to the next system information it got about the previous one. I suspect that the problem is in the plug-in, however. It looks like an unitialized variable issue.

Has anyone else noticed this problem? It could be related to my ancient browser, too. (Firefox 3.6.28)

6
Problems / Combat reports not submitted
« on: 15 October 2012, 11:21:26 »
I just noticed that no combat reports have been submitted to GT since the introduction of OGame version 5 in September. After turning on the debugging in the plug-in (version 2.6.21), I see the error "Error in parse_Messages:TypeError: overlay is undefined" when opening a combat report message. Obviously, the problem has something to do with the idiotic new pop-up windows in the game, because espionage reports (which I have configured the game to expand in the mailbox) are submitted just fine. Any ideas?

7
Problems / Unsolicited account registrations
« on: 07 October 2012, 07:57:40 »
I am using the galaxytoo-hosting.eu site as a host for my GT. The alliance name is rather non-standard and has absolutely nothing to do with the name of the alliance I am currently in (it's a leftover from a previous alliance, dissolved years ago, and in another universe anyway). However, twice already, somebody has registered an account (from the login page).

It wasn't anyone from my alliance, the account was not enabled, of course, so he could never log in - and I have deleted the account in both cases. However, how have they been able to register? In order to do that, they'd have to know the alliance name, right? Could you folks please check the security of your set up - could it have some directory traversal vulnerability or anything like that?

8
Ideas / Most profitable farms
« on: 29 September 2012, 08:03:56 »
There are 250-300 inactives in my reach whose defenses I can break. I scan all of them every morning - which is a huge waste of time (takes about an hour and a half). Then I sort the results by decreasing amount of loot and attack the topmost ones until I run out of fleet slots.

It would be nice if I could use GT to tell me which planets I am attacking the most often. They are not necessarily those with the highest mine of any particular type. Many of the most productive ones have other attackers much closer than me and they are being farmed to the bone before I can reach them, so the often don't even reach the top of the table that is sorted by decreasing order of available loot.

I can get a list of combat reports - but I can sort it only by alphabetical order of the victim's name or by date - I can't count the reports per defender and then sort by that count.

It would be nice if GT could answer the question "which players/coordinates a given attacker is attacking the most often between given dates", based on the information in the saved combat reports.

9
Problems / The dreaded "Wrong universe" error again
« on: 23 August 2012, 16:44:13 »
Since GT 5.0 was introduced (and the plug-in started using the logon key), I have started getting occasionally the dreaded "Wrong universe!" error again.

Unfortunately, I don't know how to reproduce the problem. It happens rarely and then disappears all by itself. It doesn't happen on any particular page - I've had it happen when looking at espionage reports, combat reports, the first fleet dispatch page, etc. I think that in all cases I've had a GT page open in another tab of the browser, but I'm not sure; have have it so very often and the problem occurs only rarely.

When exactly does the plug-in report this error?

P.S. OK, just managed to catch it again. There was no GT page open in another tab. Turned on the debugging and this is what I got:

Code: [Select]
Fleet page found
Target URL:http://en.galaxytool-hosting.eu/age/secret/galaxyplugin.php
Data to send:

<?xml version="1.0" encoding="UTF-8"?>
<planetinfos xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="planetinfo.xsd">
<header version="2.6.18" universe="" debug="true" language="english" token="0dff8373d9a5d17a590033c967a4f1bd" content_type="planetinfo"/>
<planetinfo playername="bontchev" playerid="100072" planetname="Centax (Moon)" moon="true" galaxy="3" system="137" planet="12">
<entry name="Metal" amount="459553"/>
<entry name="Crystal" amount="196715"/>
<entry name="Deuterium" amount="27118"/>
<entry name="Energy" amount="0"/>
<entry name="Light Fighter" amount="2"/>
<entry name="Heavy Fighter" amount="5"/>
<entry name="Small Cargo" amount="140"/>
<entry name="Large Cargo" amount="4"/>
<entry name="Colony Ship" amount="1"/>
<entry name="Recycler" amount="2"/>
<entry name="Espionage Probe" amount="107"/>
</planetinfo>
</planetinfos>


Details:

Wrong universe - actual: ""  expected: "44"


Wrong universe!

How is the universe number determined and when can the plug-in decide that it is empty?

10
Problems / The new GT
« on: 15 August 2012, 05:34:05 »
WTF happened with the GT pages?! I no longer see a thing! Just the background with some tiny strip at the top!

I was able to see the beta version while it was still in development just fine!

11
Problems / OGame 5.0
« on: 14 August 2012, 05:20:31 »
I see in the news header here that the toolbar for OGame version 5.0 will require Firefox 4.0+. Well, I am one of those 150 Firefox 3.x users and I really, really, really rather not upgrade. >:(

What exactly is the problem with OGame 5.0? What features do you require, in order to support it? Can't you support it at least partially for the older browsers?

12
Problems / Recycler debris
« on: 27 June 2012, 19:34:43 »
A spy report shows a fleet consisting of only 130 recyclers stationed at a moon (picture 1). The Search in Reports shows that the fleet at this moon will leave 59 recyclers' worth of debris (picture 2). That can't be true. By my calculations, the debris should be 32 recyclers' worth.

13
Ideas / More search conditions
« on: 12 April 2012, 05:42:52 »
It would be nice if when searching the reports, one could specify that one wants only reports from moons, or only from planets, or from both.

When searching the database, currently it is possible to search only for players with a moon. This should be a bit more flexible. It should be possible to specify that the search should include either "players that have a moon", or "players that don't have a moon", or "it doesn't matter". Currently, the second option is not possible.

And while we're on the subject of searching, currently one could search only in espionage reports submitted by himself. It would be nice if it were possible to search only the espionage reports submitted by a particular existing GT user.

14
Problems / Alliance names beginning with a dash
« on: 28 March 2012, 15:04:26 »
Does GT have problems with alliance names that being with a dash? Somebody on the Russian board is getting this kind of error:

Quote
MySQL error occurred while selecting alliances by name
Illegal mix of collations for operation ' IN '
SELECT distinct(id),allyname,diplomatic_status, ogame_allyid FROM alliances WHERE allyname IN ('-ИН-','СССР','UFH','03RU')
OR ogame_allyid IN('4','166','898','1439') AND ogame_allyid > 0

15
Problems / Installation problem
« on: 19 March 2012, 22:07:19 »
I am trying to install GT for an acquaintance on a free hosting site. The site claims to be using the latest version of MySQL, has no advertisements and the terms and conditions don't prohibit the installation of GT.

After running the install.php script, everything seems fine (see attachment). The login page is also displayed. However, when I try to log in as "admin" with password "galatool" I get the following error message:

Quote
Table 'u698290696_gt.usertable' doesn't exist

According to the MySQL control panel, the database u698290696_gt does exist. Any idea what might be the problem? Is this caused by the dreaded lack of TRIGGER rights again?

Pages: [1] 2 3 ... 7