Author Topic: Esp Reports not uploading if bandit status (Multiple Debug info inside)  (Read 997 times)

Offline Ikinboy

  • **
  • Posts: 9
    • View Profile
Hi,

I've seen some other posts with issues about the GT not working for probes. I've done some tests below which might help?

I am using Firefox 44.0.2 with GalaxyToolBar version 2.7.1 and GalaxyTool version 5.1.0
Esp report updates only work if you do not hide pictures in reports.
It doesn't work for any target who is a bandit.

I don't have a high enough esp tech to get all details but the debug info below might still help?
I might have also irritated the rank 1 player in the uni xD

Emporer - Honorable: (Works)
(click to show/hide)

Star Lord - Not Honorable: (Works)
(click to show/hide)

Star Lord - Honorable: (Works)
(click to show/hide)

No Rank - Honorable: (Works)
(click to show/hide)

No Rank - Not Honorable: (Works)
(click to show/hide)

Bandit - Honorable: (Does not work)
(click to show/hide)

Bandit Lord - Honorable: (Does not work)
(click to show/hide)

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Thanks, that is great!
Now when you are using Firefox and you are familiar with the developer tools of it, then please open such a report, rightclick it and then"Inspect" to see the HTML representation of the page. I would need the HTML representation (rightclick in the HTML Tag which is the root element of the hierarchical display of HTML tags which you see in the developer tool of Firefox) to understand how they are constructed and then adjust the parser.
I do not have bandits in the test universe nor bandit lords, that's why I cannot test this easily.
Put the HTML in here, or send it via email to me.

Offline Ikinboy

  • **
  • Posts: 9
    • View Profile
I've emailed you hopefully the right information :)

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Hi,
thanks for the information! I am unable to verify whether my changes work or not. So I uploaded a version 2.7.4 for Firefox. As soon as it got reviewed, please install it and let me know if it works as expected. If it does, I will ask Omar_Hawk to trigger the same version upload for Chrome as well.

Thanks!

Offline Ikinboy

  • **
  • Posts: 9
    • View Profile
Sadly doesn't look to have worked :( I'm on the toolbar 2.7.4 last updated today, looks to be the same error in the debug mode.
I'm probably completely wrong but the error mentions 'br' and I can only see this against the bandits:- <br >
It couldn't be as simple as the space? (I'm not a coder so no idea :D)

Star Lord:
(click to show/hide)


Bandit:
(click to show/hide)

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
That's why I meant it is impossible for me to retest so easy. I cannot simply create a new account somewhere, it takes a few days until I can scan someone :-(
What I am wondering is the fact that I never had a filled title seen yet like in your last reply: "Bandit Lord|All battles against bandits are honourable, which means they never flee!" This was not part of the email HTML content I got. There I only had:
<span class="honorRank rank_bandit3 tooltipHTML" title="">&nbsp;</span>&nbsp;kentaur1994
From what I can guess, the title="" is now filled on your cases. (shouldn't make too much difference though)

I am on it ;-)

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
I am sorry but I would need the HTML of the two scans which you added.
The important part got cut off from the "playername" already.

I tested the code with the HTML I got via email for player kentaur1994 where it worked fine with the implementation of 2.7.4

Update: Luckily there appeared ONE bandit lord in the test universe for which I got the HTML code :-)

Watch out for 2.7.5.
« Last Edit: 23 February 2016, 21:15:44 by eX0du5 »

Offline Ikinboy

  • **
  • Posts: 9
    • View Profile
Ok, I'm out for the rest of today but if you still need HTML tomorrow post on here and I'll grab some after work and email it to you

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Please test version 2.7.5 (Firefox only) and let me know your results.

Offline Ikinboy

  • **
  • Posts: 9
    • View Profile
It's worked now, nice job eX0du5 :)

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Okay, then I will trigger the update for the Chrome extension too.

BernardCornfeld

  • Guest
Code: [Select]
Galaxytool Status

Could not determine report data!
No espionage reports found!

Only this message apperas in the debug window when opening a report...

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Did you hide the report pictures as mentioned in the first posting here? Then it will not find any reports.