Author Topic: OGame 5.6.3 and the Galaxytool  (Read 10611 times)

Offline Omar Hawk

  • Administrator
  • ****
  • Posts: 900
    • View Profile
OGame 5.6.3 and the Galaxytool
« on: 24 October 2013, 13:55:08 »
Hi,

With OGame 5.6.3, Gameforge changed the structure of all game server domains. Therefore, the Galaxytoolbar will not automatically work on. In order to make it work again, you have to do the following:

Firefox AddOn
  • (optionally) install the latest version of the AddOn: https://addons.mozilla.org/en-US/firefox/addon/galaxytoolbar/versions/
  • go to the AddOn settings and update the OGame URL to match the new URL format, so something like: sxxx-lang.ogame.gameforge.com instead of unixxx-ogame.lang; therefore simply copy and paste any URL of the game, while you are logged on
Chrome/Opera AddOn
  • make sure, you have the latest version of the AddOn (should be updated automatically for Chrome but probably not for Opera)
  • you completely have to re-configure the AddOn, since the settings are saved with the old OGame url as key
OGame API import
This is currently broken, for the hosting solution as well as for self-installed tools.

For the hosting solution, you may follow the steps described here: http://en.wiki.galaxytool.eu/index.php/Galaxytool-Hosting and replace the old URL by the new one. Should have been done once automatically. :)

For self-hosted tools, there is also a simple solution, but you manually have to edit a file on your webserver:
  • Make a backup of the config folder
  • Open the attributes.php in the config folder
  • change the 3rd line, which currently looks like this:
define('OGAME_URL','http://unixxx.ogame.lang');
  • to the new OGame URL format:
define('OGAME_URL','http://sxxx-lang.ogame.gameforge.com');
  • You may check the correct URL format by comparing with your URL while you are logged on
  • After editing, overwrite the file on your webspace with the new one and everything should work again :)
Yours sincerely,
Your Galaxytool team
« Last Edit: 27 October 2013, 01:02:31 by Omar Hawk »

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Re: OGame 5.6.3 and the Galaxytool
« Reply #1 on: 25 October 2013, 22:10:32 »
I updated the hosting ogame server for all the installed tools. You should be able to use the import API again.
Tools which have been adjusted manually before, have not been touched.

Offline camber

  • **
  • Posts: 26
    • View Profile
Re: OGame 5.6.3 and the Galaxytool
« Reply #2 on: 29 November 2013, 21:25:23 »
I am trying to update my self-hosting tool from 4.9.2 to 5.1
I can't find this entry define('OGAME_URL','http://unixxx.ogame.lang'); in my existing attributes.php in the config folder.
I created the line myself but result is the same. Installation can't pass url validate.
Please help

Edit: Sorry and thanks eXOdu5. I opened new topic
« Last Edit: 30 November 2013, 03:45:46 by camber »

Offline eX0du5

  • Administrator
  • ****
  • Posts: 560
    • View Profile
Re: OGame 5.6.3 and the Galaxytool
« Reply #3 on: 29 November 2013, 21:42:26 »
This is probably the wrong thread for it.
In 4.x, you did not have the OGame url. It has been introduced with 5.x only.
You will have to run the update.php file and pass all requested parameter along the way including the OGame server url which looks more like "s101-de.ogame.gameforge.com" for Andromeda in Germany.